AMPページのエラーが突然でた!なんとか解決できたかも! | ぶれいくなぷれいす

AMPページのエラーが突然でた!なんとか解決できたかも!

それは2017年8月9日の出来事でした。昼休みにスマホを見るとGoogle Search Console Teamさんから一通のメールが届いていました。
開いてみると、こんなメーッセージが。

「AMP ページのエラーを修正してください」
「お客様の一部の AMP ページが弊社のガイドラインに準拠していないことが判明しました。~」

「えっ!?んっ?なに?」

文面からしてあきらかにただ事じゃないことは感じ取れました。

「レポートを開く」とあったのでクリックするとSearch Consoleにとんで以下の画面がでてきました。

AMPページのエラー_解決_02

すぐに目に飛び込んできたのは「重大度」「致命的」

今からコンビニで買ったおにぎりを公園で食べようとしていたのに、とてもそれどころじゃなくなりました。
とりあえず詳細を確認するとこんな画面が。

AMPページのエラー_解決_03

他にもでていまして、更に詳細をクリックして見ましたが、スマホで見づらいのとおにぎりを早く食べたいという気持ちが混じり合って、結果、現実逃避をしておにぎりを食べました。
そして仕事が終わり、家に帰ってAMPページのエラーの調査に入りました。

先に結果を言いますとなんとか解決できているかもです。(今のところ)
取り急ぎ、同じような症状が出ている方のために完結にお伝えしていきます。

私があまり詳しくないので、うまく説明できていないところはごめんなさい。

スポンサーリンク

調べれば調べるほど・・・

家に帰ってググってググってググりまくりました!

しかし!ググればググるほどややこしくなるばかりです!
コードがどうとかこうとか、私にはサッパリとまではいきませんがわかりませんでした。

それにエラーの該当ページが結構あったので、それを一つ一つ調べて解決するにはかなり時間がかかることが予想されました。

そこで、もう一度該当のページを見てみるとかなり前のページもエラーがでています。
ずっと疑問には思っていたのですが、なぜ突然こんなに大量にエラーが出ているのか。

そういえば、最近WordPressの更新があったので何か関係があるのかと思い調べてみましたが、それらしき情報は出てきませんでした!

しかし、ありました!私見つけました!

最近、更新をしたプラグインが!


スポンサーリンク

AMPが原因か?

ググりまくって有力な情報を見つけました!
それはプラグイン「AMP」の更新による可能性が高いとのこと!

現在の「AMP」のバージョンは0.5です。確かに最近更新したような気がします。

見つけた情報によると、一度「AMP」を停止して削除します。
そして、一つ前のバージョンである0.4.2をダウンロードしてインストールします。

参考までに画像を載せておきます。

AMPページのエラー_解決_05

AMPページのエラー_解決_06

AMPページのエラー_解決_07

ダウンロード完了後、「プラグインを追加」からzipファイルのままインストール完了後、ページのテストしたところ、なんとか解決できている(かも)ようです。

AMPページのエラー_解決_08

とりあえずよかったです。

まとめ

以上、突然出てきた「AMP ページのエラー」についてお伝えしました。
正直すごく焦りました。私と同じような症状が出た方はお試しください!

もしかしたら近日中に「AMP」の更新があるかもしれませんね。
それまでは更新は控えておきます。

スポンサーリンク

シェアする

  • このエントリーをはてなブックマークに追加

フォローする